YouTube Client for the BlackBerry Storm

YouTube Client for the BlackBerry Storm
By Kevin Michaluk on 22 Dec 2008 09:46 am
0
loading...
3
loading...
1
loading...

This isn't breaking news, but after talking to a few Storm owners over the weekend who didn't know about it yet and receiving a few emails on the good 'ole tips hotline about it, it seemed we'd better get a blog post up asap!

BlackBerry Storm owners, if you don't have it yet, the fine folks at Google Mobile have released a sweet YouTube Client for the BlackBerry Storm. To download, click the image above and send yourself the download link or go directly to http://m.google.com/youtube?dc=gyt on your Storm's browser (make sure your browser identification is set to BlackBerry.

Topics: BlackBerry Apps

Kevin Michaluk Kevin Michaluk "Founder, Editor in Chief " 3922 (articles) 3285 (forum posts)
65 comments

pipotobe

I can't wait to try this.
I will let you know once installed

Edit

Got it, first app installed.
Works pretty nice.

Taurinh24

so, far loving it! very smooth, very quick, the scrolling through videos is smooth and looks great. video animations and menu transitions are nice and smooth. Actual video quality seems kinda meh, sound is great! but, video seems more pixelated than normal seems like a much lower bit rate than normal. i will let yo know more as i mess with it.

over all, fantastic program for the storm, smooth and sexy. great for watching those videos of technoviking!!!

Update:
after going through menus and my account, i dont see anywhere to up the video quality, i mean, its not bad, but it could be better. over all still a great app.

searching is nice and easy saves recent searches. easy to get into your account.

EDIT!

one other thing, if watching a video, and you get a call, lags a bit on the call showing up, if you hit answer, it works fine, and when you o back into the youtube app it resumes fine. maybe that will be an OS fix not a youtube fix.

next: i will try uploading a video from my tele.

mannyfresh24

but do you have a storm 2. i cant see you tube videos in my storm 2. cant anyone help me out..

mungera

I want to know who has 551 messages!!!!!

BK in NJ

I installed this yesterday (sorry crackberry, but, another blog tipped me off over the weekend). I hope this is an indication of good things to come, because this application utilizes the Storm interface very well. Smooth transitions, easy touch screen navigation, high end graphics. I think the video quality is the same as the m.youtube.com website. If you pick a video with high quality resolution (and you have good data signal strength), you'll have an excellent experience.

Kevin Michaluk

you should read our Storm Forums.... this was in there since the 15th :)

BK in NJ

Kevin, I apologize for the comment - I now see the blog posts and stand corrected.

Butta Jones

Is YouTube video quality on the BB Storm as horrible as all the other BlackBerries? Videos are barely watchable on my Bold.

Taurinh24

honestly, i think its better than my old BB

its not too bad

Queen4111

What about a YouTube app for BB Curves!

Vin

Does anyone get any of the google install pages in German or some similar language? It's happened to me before when I installed google maps. Its no big deal just a little annoying. Is it some config issue on my phone?

pkcable

551 messages is probably Kevin. ;)

JavaDevelop

I had no idea that was out. Just got it and love it. Love the "cover flow" layout. I with the BB media player had that.

rbecerra

I think the youtube app runs smoothly, but the picture sucks.

Zargon

Like others have stated, the program looks and runs great, but the video quality sucks, bad. Sound is just fine.

BBVdo

yt mobile video quality is awful. Videos on our site are encoded in a higher resolution, and you can download the videos directly on your BB

wezra

Got the link and it sends me to page with a bunch of news articles!

Just got the Storm 2 days ago and having major issues trying to figure out how to do a search once I put the URL into the search window. This is much harder then my 8820 and I am not sure if the trouble is worth it.. I may be moving on to the Bold!

wezra

Well folks... trying to download this particular link.. and not having any luck doing it, drove me to totally reconsider the Storm. That and the fact that I spent at least 6 hours on the phone over the weekend with Verizon trying to get my MSN email account to work.. which it never did correctly. So after a 4 day love/hate affair... back to Verizon she went. It was to bad.. I really wanted the Storm to work for me. But it just isn't made for pure business use. Not the devises fault, it is really RIMs answer to the iPhone and I should have realized that. So off to AT&T I went and got the new Bold. Much better for what I need a BB for. I love the Storm.. but just not for me. So its off to the 9000 forum for me....

ScootD

in the screen capture is 551. Wow, get much email?

Anonymous

it doesn't work on my storm...I have software version 4.7.0.83 and it tells me error please restart video on every video i try to play....any ideas?

dalton_024

I keep getting the following error when I try to play a video:
net.rim.device.api.system.ControlledAccessException

What is going on? Do I need to change any settings?

waazzupppp

This is a software access error...

To fix, just go in to:

Options > Advanced Options> Applications> Youtube > Edit Permissions >

Make sure all three options say 'Allow'

This will fix the access error...

jackpa

I have this same error and I am not able to change the options to allow. The allow shows up, but it always defalts to custom.

hpfanatic

I like it and it works well for me

zahar

My Storm shows full 3G signal but I haven't been able to watch anything so far. Just keeps saying Loading.

Snowman81

No Youtube app for the Bold? I'd love to get a Bold and even though watching Youtube on the Bold wouldn't be a priority for me, it would still be nice to able to.

Anonymous

you have been able to watch youtube on BBs since the 4.5 betas were released. This is just a stand alone application for it.

just point your bold browser to:

http://m.youtube.com

I've been watching them on my 8300 Curve for a while now.

Anonymous

LOLZ Kevin!!

No one commented on the video he has highlighted in the picture. Shameless plug for Pudding Wrestling.....rofl

tahfllfl

Hey Gang, Anyone know why the new Storm does not have any
streaming audio via their media player. Cannot listen to any radio programs. thanks, tom

Anonymous

I get an error
Error initializing media. Cause:
javax.microedition.media.MediaException:Error initializing media.

What's up?

boosted98taco

Error is "PlayerException: Cannot open tunnel Cause: java.io.IOException: Cannot open tunnel.

YouTube Permissions are all set to Allow. Any help greatly appreciated!

sardine314

same error. help much appreciated!

pavo32

hi, just wondering if any one know how to fix this problem?
thanks

AtomicFireball

Hello:

Hit BB menu button:
Options:Memory:
Auto Enable Mass Storage Mode When Connected: Yes.
Save and exit.

This worked for me hope it works for you!

lost blackberry user

When you download the YouTube client on the Blackberry Storm how can I get an Icon on the home screen? I had it on the "Switch Application" but, now i have no clue where it is? Can someone help me find it?

Oh, one more thing, really another subject...the media manager on my desktop is always shadded and I can't use it. How do I get this to work?

Thanks,
Lost

quade82

So i read this thread and did everything people have suggested but I'm still not able to use YouTube.

When I search for a video I get a connection error reading:

(java.lang.IllegalArgumentException: expecting small float)

I'm running OS (.132) on my Storm...

any suggestions?

Ziki Torres

Yeah man i get the same same prob as you ,, did you find out how to fix it .. let me know please .. thanks ...

Ziki Torres

Hi there , i just got my Blackberry Storm , its nice and everything but , i'm having problems with my youtube .. it keeps telling me java.lang.illegalstateException ... thats after installing the youtube app. from www.bwone.com

and when i go straight on to youtube.com the video doesnt play it stays black,,

anyone here know what to do ?? thanks ..

wcmarchese

Any word on this coming to the other blackberrys? I'd like full screen YouTube, even if it was low quality.

WCM

cpanuska

I have always been able to go 1 1/2 days with out charging my Storm and I am on it ALL the time for work and personal usage. I thought it would be fun to add this app... After downloading I could not go more than 4 hours with out having to charge my phone. This was the last app that I have loaded and the only app that I have deleted...

gunmetal44

each time i do the steps my bb storm 9530 says "device not supported" but i had it on my old storm 9530. cant figure it out. ideas?

dchup

gunmetal44 - same thing happened to me - it appears the youtube app isn't compatible with the recent storm 5.0 software upgrade

NateTheApe

Yeah, the YouTube App isn't supported for the Storm 5.0 OS it didn't work on my Storm2 either

Mochasoul05

So I tried to get this app, but it is telling me that my device is not supported?

dgburns

I too have been trying to get it to download to my Storm with OS 5.0.0.328 but no luck. Worked flawlessly while I was still running 4.7 but disappeared when I upgraded to 5.0.

I have tried the "workarounds" suggested in the google forums (set browser to firefox, download client from some lpcsolutions.com web site, etc.) but get nowhere with them either.

jazzpr

Since I'm on .328 I can't get it to work... every time I end up with the "blabla isn't supported"-message.

Is there a solution/workaround yet?

Super Vervet

Every time I try to go to m.google.com/youtube?dc=gyt, I get the message DEVICE NOT SUPPORTED.

Does anyone have the same problem? Any ways around this? I can't watch youtube at all directly on the website (another error message.)

Thanks for your help.

Harris

Super Vervet

Sorry, forgot to add. I'm using Storm 2.

Thanks

FunkyDog

Device not supported for me too. I'm on a Storm2 using OS5.0.

jziggity

SAY IM IN THE MIDDLE OF WATCHING A VIDEO ON MY YOUTUBE APP ON MY PHONE AND A PHONE CALL OR TEXT COMES IN...

I TAKE THE CALL OR TXT AND THEN I RETURN TO MY VIDEO AND BOOM! IT RESTARTED BACK TO THE BEGINNING~!!!!!!!!!!!!!!!

~~~~~~~WTF??!!~~~~~~~~~

IS THERE A RESUME FEATURE SOMEHERE ON THE PHONE PLEASE HELP~!!

THANKS

Papasmurfrocks

If you come across this message "PlayerException: Cannot open tunnel Cause: java.io.IOException: Cannot open tunnel" then you need to enter APN settings. Options>Advanced Options>TCP/IP and enter your carrer settings. I am using OS 5.0 and after i entered the settings Youtube worked fine without any error. Just google to find out your carrer APN settings.

Regards

chezg

Helllllppppp mmeeeee I have v.5 I nedd it what can I do?

storm83

I had youtube with 4.7 and 5.0. now i tried to install it and its not supported. BOOOOOOOOOOOOO

farrelldoc

When I go to the site, it says my device is not supported. I have a BB Storm 9530 with OS 5.0.0.328. I have my browser identification set to BB also. Bummer.

Is anyone else running the YouTube app under that platform?

nv1z

I bought my 9530 beginning of October, 2009 and I have the same issue with a bunch of apps that used to work on my 9530, It seems to be tied to the "automatic system upgrade" that happened during one of my synchronizations. I have Blackberry Desktop Manager configured to automatically start synchronization when BDM is opened and my 9530 is connected to base computer's USB port.

Some time after my 9530 upgraded from 4.2.x to 5.0.x my Blackberry Maps stopped working. The folks at Verizon didn’t know why. I had to do the detective work. Finally I found somewhere that actually explained that Blackberry Maps worked under 4.2.x and not under 5.0.x. Google Maps became the standard Blackberry Maps application.

Also my VCast Song ID is no longer available on Blackberry, and now, neither is YouTube. I’ve tried both the “send me an SMS link” option as well as m.google.com/youtube browser method. Neither works. WTF is going on here?!?

Oh, and yes, I tried Blackberry mode (and Firefox mode and Internet Explorer mode.) Also the link sent to me was not active (highlighted) when I tried SMS text method

Apparently this has been a problem since 11/21/09 (or before) and now it is 12/31/09 and still no sign of resolution.

Apparently there is a free "hobbled" version of the application "Shazam" which identifies songs similarly to VCast Song ID and works fine as much as I use it. But what about YouTube? It used to be a free app and now there is (apparently) nothing that plays YouTube on my Storm 9530.

souvickmitra

The new Storm 2 9550 that I got from a local Verizon store turns out to be a real piece of ... work. While playing around with it for a little bit, I found that YouTube videos - that were working a half hour earlier - stopped working altogether. Once I click on a video to load it, it says 'Loading' and then the screen turns black, and nothing else happens. Thinking that this may be a problem with the weird browser that came with the BBS2 (videos from my own media played fine), I tried to download the YouTube client recommended by Crackberry. No joy. "Device not supported" - tried Blackberry mode, Firefox mode and IE mode like the user above. Nothing.

I am surprised that a company like RIM can belt out an advanced phone with such crappy software on it.

hurricane_ditka

Tried reloading after recieving another Storm and it says it's not supported???

Stides

It looks like it's more of a google download page problem than a true non-comparability problem. I found a link to the app that was posted somewhere else and downloaded it to my storm 1 with os 5. Seems to be working. However, I notice that the buttons for stop, play, ff, and rw have to be pushed several times for them to work. I also don't know if this is the most recent version.

http://www.p3designs.info/files/youtube.jad

just use your bb browser set to identify as bb.

BonezH2X

http://stormota.com/150

I really liked my youtube app on my 9530 and have been missing it since my upgrade but now I have it back.

steveasir

Dear Sir,

I am holding BB Storm 9530. I have installed the YouTube as you have said in the site. My problem is, when I play a video it says, "Video was interrupted. Please restart the video" I don't know how to solve this. Kindly help me in this.

neptunefreak

SOMEONE PLSSSSSSSSSS HELP ME WITH THIS ... GETS THE MSG SWITCH TO WAP FOR STREAMING ON STROM 9530 WITH AIRTEL SERVICES. JUSS BROUGHT TO PLAY YOUTUBE VIDEOS...
ONE OF MA FREN IS USING THE BB BOLD WITH AIRTEL SERVICES BUT THE YOUTUBE VIDEO PLAYS JUSS FINE...
PLSSSS HELP ME WITH THIS.......

neptunefreak

SOMEONE PLSSSSSSSSSS HELP ME WITH THIS ... GETS THE MSG SWITCH TO WAP FOR STREAMING ON STROM 9530 WITH AIRTEL SERVICES. JUSS BROUGHT TO PLAY YOUTUBE VIDEOS...
ONE OF MA FREN IS USING THE BB BOLD WITH AIRTEL SERVICES BUT THE YOUTUBE VIDEO PLAYS JUSS FINE...
PLSSSS HELP ME WITH THIS.......