Leaked: OS 5.0.0.612 For The BlackBerry Storm2 9520

Leaked OS 5.0.0.612 For The BlackBerry Storm 2 (9520)
By Bla1ze on 11 Apr 2010 01:21 pm EDT
0
1
0

If you're a Storm 2 9520 owner you'll wanna set aside a few minutes to check out the latest leak. OS 5.0.0.612 has just hit the internet for all to grab. At this point, we're not sure if it's a DRM version or not so we'll leave that for you all to figure out. Let us know in the comments and as always, back up your data before you load this one up.

*OS Disclaimer - Please Read: Keep in mind this is NOT an official release and as such is not supported by RIM or your Carrier. If you choose to install, do so at your own risk and only if you're comfortable in the process of upgrading and downgrading your device software. It is quite normal during operating system development for certain features to be crippled or disabled while others are tested, and these beta builds often reflect that. They are not always better. Depending on your BlackBerry comfort level, it may be best for you to wait for community feedback on a build before deciding to download and install for yourself or simply wait for the next official release. If you require support, you will find it in our CrackBerry forums via our extremely knowledgeable community base - do not contact your carrier or RIM for Beta OS technical support (their first course of action will be to advise you to downgrade to a supported OS). Follow the links below for more information and instructions. *

Source: BBLEAKS

Reader comments

Leaked: OS 5.0.0.612 For The BlackBerry Storm2 9520

12 Comments

can i just copy rim0x0D001404.sfi to the new OS' CDMA folder to make it become a DRM version? THX a lot!

after downloading and extracting I knew for sure that this contains 'rim0x0E001404.sfi' (and not rim0x0D001404.sfi) - so this can't be installed on my Vodafone Storm2... So still sitting on my v5.0.0.580 - P4.2.0.250 (from Vodafone Egypt)

Hi i need some help, i have a factory unlocked/unbranded Storm 9520 on orange uk what OS version should i use of this? Thanks.

Hello guys i've read your comments but i can't find solution to install os for my blackberry storm 9520. I did delete those two vendor and tried to goto app loader and then pop up messege with the blackberry desktop does ont have blackberry for divice conected, sometime its shows up blackberry core 5.0.0 but it does not show system software to install... I downloaded two blackberry softwares, one with 9520 v5.0.0.1077 nd one is 9520 v5.0.0.496 all with rim0x0d001404
please help