Fieldrunners 2 arrives in BlackBerry World but you'll need BlackBerry 10.2 to run it

By Bla1ze on 29 Aug 2013 12:19 am EDT
0
loading...
0
loading...
48
loading...

If you're into tower defense games then you no doubt have already gone hands-on with the original Fieldrunners at one point or another. The follow-up to the original, Fieldrunners 2 was released for iOS and Android not all that long ago but the studio behind the game, Subatomic, has now gone ahead and released the game for all BlackBerry 10 devices - kind of. I say kind of because as of right now, it shows you need to have BlackBerry 10.2 or higher, which we all know can only be had by installing a leaked version of the OS.

The fieldrunners are back! With legions of soldiers and a gaggle of new tricks, they're ready to conquer the globe. Or so they think! Our top scientists at SubaLabs have built a bleeding-edge arsenal of devastating weapons for any heroes willing to stop these dastardly invaders. Help your people by taking action - DEFEND THE WORLD!

Strategic-Action-Puzzle-Defense has never been this fun and addicting! Defend your world from the invasion by building winding paths out of imaginative, new weapons. Call in air strikes and set explosive traps to hit the enemies where it hurts. Over 20 new levels span the grassiest fields, driest deserts, sparkling cities, and even an infernal volcano lair! Challenge your mind with the exciting new gameplay styles in Puzzle, Sudden Death, and Time Trial levels. Are you ready to stop the fieldrunners once and for all? Join the defense, now!

Honestly, I'm 99 percent sure I'm only seeing it in BlackBerry World because I'm running the latest 10.2 leak. It seems as though anyone running anything less than cannot even find it in BlackBerry World so if you're on the leak and want it, I suggest you pony up the $2.99 they're asking for the awesome game and grab it quick because the listing may not stay live for long at all. In any case, we know Fieldrunners 2 is coming to BlackBerry 10. Ooopsy!

Purchase / Download Fieldrunners 2

Reader comments

Fieldrunners 2 arrives in BlackBerry World but you'll need BlackBerry 10.2 to run it

50 Comments

Cute.

I can see it but yup, not available for my device. Would have to get the leak.

It's interesting what BBRY will allow in their app space. Here's another app developer with a pretty novel approach to monetizing their product.

Posted via CB10

Don't worry I'm in Toronto Canada and got my Mr update just last week. I got hyped up over nothing since nothing was really new in my opinion.

Posted via CB10

Very interesting how there are apps on BlackBerry World that only work on future versions / leaks.
That's pretty cool. In a way BlackBerry is getting around carrier updates and providing the OS updates indirectly and supporting it with BlackBerry World.

Why not create a mechanism where users can petition developers to port their Android apps into BlackBerry World as well.

- aBBuser

Is it native..? Or do they require 10.2 because it needs the latest JellyBean Android Runtime?

I'm not spending $3 if this is an Android Port, but if it's native, I'm going to jump right on it, can anyone inform me?

EDIT: Scratch that, I purchased it because I couldn't wait for a response.. And it's native! WOOHOO :D Wonder why the 10.2 requirement, probably a mistake by the devs :P

So happy to see all of these great apps/games coming to BB10 the past couple days!

I purchased it and it won't open, after showing up then it just automatically closes itself. I wonder what's wrong -___-

STL 100-1 Running on 10.2.0.1047 Leak

There's a few 10.2 apps now in app world. I'm hoping that this means the official 10.2 is very close.

Posted via CB10

I'm running 10.1 and i found it in BlackBerry world but it is unavailable for my device just thought I'd share the info lol

Posted via CB10

Got the game its great I love it! Dont forget to leave reviews guys, helps these better games get to those trending and top lists :)

Just went to go do that but it's not showing up for me anymore :( I bought it already though, so whatever, I'll review it later :)

- Developer of 'Web Design Cheat Sheet' for BB10 (Posted via CB10)

It is native, there might be some components in 10.2 that this game required specifically, just because it requires 10.2 does not mean that it's there because you need the new JellyBean Runtime. It's 100% Native, and will probably be BfB Certified soon enough. Game integration, runs perfectly, awesome game - worth the price.

Really appreciate the devs coming and developing this all-star game for BlackBerry too :)

I get a "This app cannot be purchased error" on the payments page, as I clicked download. I am in Singapore on 10.2

Posted via CB10

This is becoming predictable of blackberry ; staggered OS updates and now staggered apps. I don't do leaks and i can't download the app. I shouldn't need to side load a OS to get apps for a OS that is not officially released.

If BB is going to die, then they should hurry the f**k up and put us out of their misery.

Posted via CB10 on my Z10

Hey guys, just a heads up that we *just* uploaded a new build that works with 10.1. Sorry for the confusion. I hope you enjoy our game!

All right, I just added BlackBerry 10 support and BlackBerry World link in the game's Wikipedia article.

Marketing is everything