BlackBerry PlayBook

Grab a bargain with a BlackBerry PlayBook at under 80 bucks

News & Rumors

Grab a BlackBerry PlayBook for $69.99 today only from eBay

Devices

From the forums: The BlackBerry PlayBook 10 concept and this one looks a real beauty

PlayBook Apps

CascaRun Sports Tracker Pro hits the BlackBerry PlayBook

Editorial

CrackBerry Mailbag: The Death of the PlayBook

Devices

BlackBerry PlayBook OS support officially ends this April

BlackBerry Tablet OS

BlackBerry PlayBook updated to OS 2.1.0.1917

CrackBerry Polls

60% of BlackBerry PlayBook owners are still perfectly happy using their tablets

BlackBerry Apps

BlackBerry still actively working on PlayBook OS updates, Bridge update now available

From the Forums...

What features would your ultimate BlackBerry PlayBook 2 have?

PlayBook Games

Flappy Herbie makes his way to the BlackBerry PlayBook

BlackBerry Apps

View phone call notifications on the PlayBook with the latest update to BlackBerry Bridge

CrackBerry Polls

CrackBerry Asks: Do you still use your BlackBerry PlayBook?

BlackBerry Accessories

Sky Drone aims to give BlackBerry 10 device and PlayBook remote aerial viewing

Devices

Get a 64GB BlackBerry PlayBook for just $130, but you have to act fast!

CrackBerry Polls

CrackBerry Asks: Are you picking up a new tablet or sticking with your BlackBerry PlayBook?

Editorial

CrackBerry Report Card: PlayBook owners' plea

Interviews

BlackBerry CEO on BB10 for PlayBook: "It was one of the toughest decisions I had to make"

Devices

RIP BlackBerry PlayBook: 2011 - 2013

BlackBerry Tablet OS

BlackBerry announces BB10 is not coming to PlayBook

< >

Uncovered: BlackBerry PlayBook OS 2.0 Uses SwiftKey Keyboard!

SwiftKey Keyboard on BlackBerry PlayBook OS 2
By Kevin Michaluk on 21 Feb 2012 11:16 am EST
10
loading...
0
loading...
74
loading...

Well, that didn't take long to figure out. One of the enhancements within BlackBerry PlayBook OS 2.0 is an updated keyboard, which includes some nice new features over the original PlayBook OS keyboard. I love how the keyboard now inserts the number row above the letters when filling out fields and also love the addition of text prediction, which was lacking.

Absolutely loving PlayBook OS 2.0 this morning, I called up Phil Nickinson, our Editor in Chief on our sister site AndroidCentral, for a little video chat to show off to him some of the OS 2.0 hotness. As soon as Phil saw me typing on the keyboard he said, "type in Phil... do you get Collins?" Sure enough, after typing in Phil and hitting the space bar, "Collins" was autosuggested. I showed Phil a few other things, and then he stopped me after I typed another name. Ben. The first word suggested was the name "Medlock." Phil got excited. Or mad. Can't really tell which. "Congrats... that's SwiftKey."

It turns out Ben Medlock is the CTO of SwiftKey, a third-party Android keyboard, and that's a little pre-programmed autosuggestion they put into their autosuggestion. Along with Swype, SwiftKey is one of the big and awesome third-party software keyboard technologies/developers out there. And while we haven't seen any official acknowledgement from either BlackBerry or SwiftKey on this one yet, without a doubt we can say PlayBook OS 2.0, and it looks like BlackBerry 10 will be rocking SwiftKey technology on the keyboard front in some form, either officially or behind the scenes. 

Reader comments

Uncovered: BlackBerry PlayBook OS 2.0 Uses SwiftKey Keyboard!

33 Comments

Swift Key is awesome. Really one of the best. Hats off to RIM. They really have excelled. I hope this translates in an upturn in profits for them after all their hard work

Thats awesome. And explains why it looks familiar i use swiftkey on my android device. Great keyboard on the PB.

THOR IS ALREADY BEGINNING TO "DELIVER"...VERY REFRESHING...2.0 MAY, FINALLY, GET THE PLAYBOOK SOME OF THE RESPECT IT DESERVES.

KEVN - GREAT JOB ON POSTING THOSE NEW PLAYBOOK COMMERCIALS, THIS MORNING, THE 2ND ONE HIGHLIGHTING "MICRO USB TO TV" IS HUGE!!!!

That function has always been there... and it's not the micro USB port being used its the micro-HDMI port that the playbook has always had.

Ok, I had to turn autocomplete off.
I sent a couple messages with "lollipop" in them where I had written "lol". Reeeetarded.

If it is indeed SwiftKey, then the autocorrect will learn your habits and will eventually default to lol instead of lollipop. Just needs a little time to learn your habits.

Interesting. But not enough for me to leave autocorrect enabled. It incorrectly "auto-incorrected" two words and I almost didn't catch before sending. I don't need the computer scrambling my words while it learns my habits.
But the auto-suggestion feature - that's terrific!

Settings > Keyboard > Automatically correct as I type.
It will autocomplete or autocorrect a word for you.
Example: You type "teh" it will change it to "the".

For some reasons it assumes "lol" is "lollipop".

I know on my Droid Bionic, you can change that. If you just select the one that says "lol" instead of "lollipop" after 2-3 times it will remember it. I'm sure it's the same on the playbook but not 100% sure.

I love swift key. I was starting to wonder if this was the same keyboard app.
The more you use it the more it adapts to your grammar style. This is awesome.

uno u could change the autocorrection u could've disabled "lol" correction instead of the whole thing

The keyboard doesn't seem to "pop up" when it's supposed to. It should, and used to, pop up whenever you were focused in a text window. I've been constantly having to swipe up from bottom left to bring it back up when it should just be there. It's happening in the native email, bridged email, web pages, etc. Very annoying.
Also, the predictive text, spell check, auto correct has done nothing for me yet? On misspelled words, it underlines, but does not offer a correction, it only offers to add the misspelled word?
Am I missing something?

well, I feel silly. A reboot fixed it up. I guess I didn't reboot after the initial OS 2.0 install/reboot. It's working as expected now.

If it is SwiftKey then it's the most intuitive version I've used, and that can only be a good thing. Though from what we've heard of OS 3 I wonder if it's a temporary measure before a whole new thing or if it will be a new skin.

Either way for now, job very well done!

I love SwiftKey on my SGS. This is a great additional to the Playbook. It can get kind of freaky with how many words it can predict in a row. I had actually typed out the same tech support email to a few people. After that, it actually was able to write out the entire email just by typing a couple of the first words. Definitely saves a lot of typing!

Too bad third party apps needs to be modified to accommodate it. I tried in GroovyNotes and it still gets the old keyboard. I would have loved for it to be the default keyboard.

In my Pb the swiftkey appears ramdonly, also pops up ramdomly when it's supposed to popup at a text entry box, had rebooted twice and no fix :-s

I love it, makes typing much easier. Often typing two letter is enough to get the right suggestion.
Great!

Can someone provide clarification about the number row showing feature showing on the keyboard. I am. Not seeing this. Thanks in advance.

I feel duped by RIM- the Android player everybody thought we were gonna get- we DIDN'T get and what's more...there aren't ANY decent Android apps in app world they all suck! I thought we were gonna get the Android that ACTUALLY plays ANDROID and we can open and download Android apps from the Android Market but NOPE! There isn't ANY IM Apps still- Skype, Yahoo Messenger, OoVoO or anything just the sucky video app that belongs to RIM and which I can't use cause nobody I know has a PlayBook! Then there's the books, I'm going to college and Kobo doens't have crap of the ones I need so I figured with Android we would get Amazon, Kindle, etc... NOPE! Not even a decent Navigation App... we didn't get anything, as far as I can tell we got duped...again! I've been so caught up in the bridge remote that the more I've been thinking about it the more I get pissed. So now, what can I use my PlayBook for...surfing the web! TOTALLY USELESS!!!

Ummmmmm this may be a daft question but here goes anyway. After upgrading the OS I went immediately to the new messages program to set up, and whilst completing email addresses etc.... the numbers sis indeed appear above the letters - absolutely delighted!! However this seems to be the only instance where this occurs. I don't get numbers on emails I reply to, spreadhsheets, search bar entries on browser or app world........... in fact I can't seem to get them for anything else at all.
Does anyone know how to fix this? I've been in the settings -> keyboard options but there's no option to turn this feature on or off!

Please help if you know what I'm doing wrong as the old version of having to press the 123 button every time is really annoying!!